Results 1 to 3 of 3
Discuss 1993 Ford Ranger engine revs w/o gas pedal in the alt.autos.ford forum at Car Dealer Forums; Hi all, I have a problem with my 1993 Ford Ranger. It stated about a ...
  1. #1
    brianpkennedyut
    Guest

    Default 1993 Ford Ranger engine revs w/o gas pedal

    Hi all,

    I have a problem with my 1993 Ford Ranger. It stated about a week ago,
    the engine would idle at a very high RPM (3000 or so), but it would
    only do it sometimes. Also the engine would rev up to 3 or 4 thousand
    RPM sometimes when i pushed in the clutch to change gears. Sometimes
    it would fall when i put it in gear, sometimes it would fall if I
    pushed in the gas. However, today really concerned me. Today while
    driving my truck, i pushed in the clutch to change gears and the
    engine quickly jumped up to 4000 RPM, then it fell to 2000, then back
    to 4000, then down to 2000 then up to 4 again. Then I put it into gear
    thinking that would make the problem go away, and instead my truck
    began to accelerate without me pushing in the gas pedal. As you can
    imagine this is very concerning.

    Do you guys have any ideas as to what the problem may be, and how much
    it might cost to have it fixed?

    Thanks in advance for your responses.



    › See More: 1993 Ford Ranger engine revs w/o gas pedal

  2. #2
    Shawn
    Guest

    Default Re: 1993 Ford Ranger engine revs w/o gas pedal


    "brianpkennedyut" <brianpkennedyut@gmail.com> wrote in message
    news:5a6a00a3-24fa-4641-9ef7-6e85b54870e9@v46g2000hsv.googlegroups.com...
    > Hi all,
    >
    > I have a problem with my 1993 Ford Ranger. It stated about a week ago,
    > the engine would idle at a very high RPM (3000 or so), but it would
    > only do it sometimes. Also the engine would rev up to 3 or 4 thousand
    > RPM sometimes when i pushed in the clutch to change gears. Sometimes
    > it would fall when i put it in gear, sometimes it would fall if I
    > pushed in the gas. However, today really concerned me. Today while
    > driving my truck, i pushed in the clutch to change gears and the
    > engine quickly jumped up to 4000 RPM, then it fell to 2000, then back
    > to 4000, then down to 2000 then up to 4 again. Then I put it into gear
    > thinking that would make the problem go away, and instead my truck
    > began to accelerate without me pushing in the gas pedal. As you can
    > imagine this is very concerning.
    >
    > Do you guys have any ideas as to what the problem may be, and how much
    > it might cost to have it fixed?
    >
    > Thanks in advance for your responses.


    Throttle valve sticking ?



  3. #3
    Picasso
    Guest

    Default Re: 1993 Ford Ranger engine revs w/o gas pedal

    brianpkennedyut wrote:
    > Hi all,
    >
    > I have a problem with my 1993 Ford Ranger. It stated about a week ago,
    > the engine would idle at a very high RPM (3000 or so), but it would
    > only do it sometimes. Also the engine would rev up to 3 or 4 thousand
    > RPM sometimes when i pushed in the clutch to change gears. Sometimes
    > it would fall when i put it in gear, sometimes it would fall if I
    > pushed in the gas. However, today really concerned me. Today while
    > driving my truck, i pushed in the clutch to change gears and the
    > engine quickly jumped up to 4000 RPM, then it fell to 2000, then back
    > to 4000, then down to 2000 then up to 4 again. Then I put it into gear
    > thinking that would make the problem go away, and instead my truck
    > began to accelerate without me pushing in the gas pedal. As you can
    > imagine this is very concerning.
    >
    > Do you guys have any ideas as to what the problem may be, and how much
    > it might cost to have it fixed?
    >
    > Thanks in advance for your responses.


    had the same problem with my 02 (did i ever mention i hate rangers?) it
    was the throttle position sensor. Not sure if the 93's are the same as
    mine is, but that is what fixed mine. Identical symptoms... i just
    dealt with it until i got the parts... luckily i didn't have to wait
    long i found one in a junk yard off an 05.

    Mine was an 02, 3.0L 5spd.

    I almost guarantee this is your problem

Similar Threads

  1. Replies: 2
    Last Post: 10-19-2007, 03:56 AM
  2. Hard Break Pedal And Stalling Engine?
    By Spinstorm in forum alt.autos.volvo
    Replies: 13
    Last Post: 05-01-2007, 05:11 AM
  3. Hard Break Pedal And Stalling Engine?
    By Spinstorm in forum alt.autos.volvo
    Replies: 1
    Last Post: 04-26-2007, 09:28 PM
  4. Replace Acceleration Pedal 1993 Mercedes Benz 300SE
    By nevets in forum alt.auto.mercedes
    Replies: 1
    Last Post: 02-02-2007, 08:01 PM
  5. FS 1993 Ford Ranger for parts in Spartanburg, SC
    By c_braley1@hotmail.com in forum alt.autos.ford
    Replies: 0
    Last Post: 09-12-2006, 12:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •